Viewing version 0.9.4+1. Open the latest package page.

file_selector_linux

0.9.4+1

Liunx implementation of the file_selector plugin.

Download archive

Readme

file_selector_linux

The Linux implementation of file_selector.

Usage

This package is endorsed, which means you can simply use file_selector normally. This package will be automatically included in your app when you do, so you do not need to add it to your pubspec.yaml.

However, if you import this package to use any of its APIs directly, you should add it to your pubspec.yaml as usual.

Changelog

0.9.4+1

  • Updates pigeon dev_dependency to ^27.3.2 for analyzer 14 compatibility.
  • Updates minimum supported SDK version to Flutter 3.38/Dart 3.10.

0.9.4

  • Adds getDirectoryPathWithOptions and getDirectoryPathsWithOptions implementations.

0.9.3+3

  • Updates to Pigeon 26.
  • Updates minimum supported SDK version to Flutter 3.32/Dart 3.8.

0.9.3+2

  • Updates Pigeon to resolve a compilation failure with some versions of glib.

0.9.3+1

  • Fixes a regression in 0.9.3 with handling of canceled dialogs.

0.9.3

  • Updates method channel implementation to use Pigeon.
  • Updates minimum supported SDK version to Flutter 3.19/Dart 3.3.

0.9.2+1

  • Adds pub topics to package metadata.
  • Updates minimum supported SDK version to Flutter 3.7/Dart 2.19.
  • Migrates styleFrom usage in examples off of deprecated primary and onPrimary parameters.

0.9.2

  • Adds getSaveLocation and deprecates getSavePath.
  • Updates minimum supported SDK version to Flutter 3.3/Dart 2.18.

0.9.1+3

  • Sets a cmake_policy compatibility version to fix build warnings.

0.9.1+2

  • Clarifies explanation of endorsement in README.
  • Aligns Dart and Flutter SDK constraints.

0.9.1+1

  • Updates links for the merge of flutter/plugins into flutter/packages.
  • Updates example code for use_build_context_synchronously lint.
  • Updates minimum Flutter version to 3.0.

0.9.1

  • Adds getDirectoryPaths implementation.

0.9.0+1

  • Changes XTypeGroup initialization from final to const.
  • Updates minimum Flutter version to 2.10.

0.9.0

  • Moves source to flutter/plugins.

0.0.3

  • Adds Dart implementation for in-package method channel.

0.0.2+1

  • Updates README

0.0.2

  • Updates SDK constraint to signal compatibility with null safety.

0.0.1

  • Initial Linux implementation of file_selector.

Installing

export PUB_HOSTED_URL=https://pub.mirror.p-hatan.ir
flutter pub add 'file_selector_linux:0.9.4+1'
pubspec.yaml
name: file_selector_linux
description: Liunx implementation of the file_selector plugin.
repository: https://github.com/flutter/packages/tree/main/packages/file_selector/file_selector_linux
issue_tracker: https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+file_selector%22
version: 0.9.4+1

environment:
  sdk: ^3.10.0
  flutter: ">=3.38.0"

flutter:
  plugin:
    implements: file_selector
    platforms:
      linux:
        pluginClass: FileSelectorPlugin
        dartPluginClass: FileSelectorLinux

dependencies:
  cross_file: ^0.3.1
  file_selector_platform_interface: ^2.7.0
  flutter:
    sdk: flutter
  meta: ^1.10.0

dev_dependencies:
  flutter_test:
    sdk: flutter
  pigeon: ^27.3.2

topics:
  - files
  - file-selection
  - file-selector

Version history

VersionPublishedArchiveSHA-256
0.0.1On demandDownloade21b6bd2…b7bb21
0.0.2On demandDownloada89a9307…a80cc5
0.0.2+1On demandDownloadd9b12819…b2ea51
0.0.3On demandDownloadc06249f2…3f0178
0.9.0On demandDownload0c2043ab…14a8d3
0.9.0+1On demandDownloadc3f921a9…d18633
0.9.1On demandDownload30edefcd…c37cff
0.9.1+1On demandDownload3b998328…f4e10a
0.9.1+2On demandDownload39eb2bec…565b54
0.9.1+3On demandDownloadd17c5e45…50baa3
0.9.2On demandDownload770eb1ab…580046
0.9.2+1On demandDownload045d372b…ddd492
0.9.3On demandDownload712ce7fa…2c4ab2
0.9.3+1On demandDownloadb2b91daf…84198b
0.9.3+2On demandDownload54cbbd95…617a33
0.9.3+3On demandDownload80a877f5…d4b21a
0.9.4On demandDownload2567f398…6263a0
0.9.4+1Cached · Upstream SHA-256 matchedDownloadda76400e…bcd2ab

Dependencies

cross_file "^0.3.1"

file_selector_platform_interface "^2.7.0"

flutter { "sdk": "flutter" }

meta "^1.10.0"